Loading...

Función BUSCARX en Excel

Con la función BUSCARX que encontramos en las nuevas versiones de Excel podemos buscar datos en una tabla por filas. Podríamos considerarla una mejora de la función BUSCARV, una función muy utilizada en Excel.

Con BUSCARX podemos buscar un dato en una columna y devolver un resultado de la misma fila en otra columna. De esta manera, no es necesario que la columna por la que buscamos se encuentre en la primera posición de la tabla. Tampoco tendremos que seleccionar la tabla entera ni indicar la posición de la columna donde se encuentra el dato que queremos que nos devuelva la función.

Sintaxis de la función BUSCARX en Excel

La sintaxis de la función es la siguiente:

=BUSCARX(valor_buscado; matriz_buscada; matriz_devuelta; [si_no_se_encuentra]; [modo_de_coincidencia]; [modo_de_búsqueda]) 

donde el valor buscado es el valor que se debe buscar. El argumento matriz buscada hace referencia al rango de celdas donde se buscará el valor. Matriz devuelva será el rango de celdas donde se encuentra el dato que queremos que devuelva la función.

Por otro lado, mediante el argumento si_no_se_encuentra podemos definir el valor o texto que queremos que devuelva la función en caso de no encontrar el valor buscado. Con el argumento modo_de_coincidencia definimos el comportamiento de la función si no encuentra el valor buscado. Podemos especificar los siguientes valores para este argumento:

  • 0 para coincidencia exacta. Devuelve error #N/A si no encuentra el dato.
  • -1 Si no encuentra el valor devuelve el siguiente elemento más pequeño.
  • 1 Si no encuentra el valor devuelve el siguiente elemento mayor.
  • 2 Permite usar caracteres comodín como ? o *.

Por último, con el argumento modo_de_busqueda indicaremos si la búsqueda empezará por el primer o el último elemento.

En este enlace puedes comprobar las explicaciones sobre esta función en la página de soporte de Microsoft.

Ejemplos de uso de la función BUSCARX en Excel

Disponemos de la siguiente tabla:

Funcion BUSCARX en Excel

=BUSCARX(308; A2:A15; B2:B15; “No disponible”) 

Devuelve el título de la película con código 308, es decir, CASABLANCA.

=BUSCARX(315; A2:A15; B2:B15; “No disponible”)

Devuelve el texto “No disponible” al no encontrar la película con código 315

=BUSCARX(308; A2:A15; D2:D15; “No disponible”)

Devuelve el precio de la película con código 308, es decir, 3,60 €

=BUSCARX(“Solas”; B2:B15; A2:A15; “No disponible”)

Devuelve el código de la película SOLAS, es decir, 313

Excel Avanzado con ejercicios prácticos

Esta entrada es parte de nuestro curso de Excel Avanzado con ejemplos prácticos. Por lo tanto, si lo deseas, Accede al curso para conocer todo su contenido

Deja una respuesta

Tu dirección de correo electrónico no será publicada.